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Workflow MS 10 - Converting AutoCAD Files to 
MicroStation

This document guides you through translating AutoCAD files into MicroStation using a .CSV remapping file. 
The MicroStation dgn files produced using this workflow will have standard CDOT levels using bylevel 
symbology. For plotting AutoCAD files only, see the workflow, CDOT Printing AutoCAD Files in 
MicroStation. 

Workflow Outline

Batch Conversion Of AutoCAD Files - All of the file within a directory can be converted at one time 
using Batch Processing. Because the level conversion table will be set up for only the open drawing it may no 
convert all AutoCAD level into Microstation levels. When these unconverted levels are discovered, repeat this 
process to convert the remaining AutoCAD levels.

♦ Commands Used: File > Open - Used to access the MicroStation Manager dialog box. From there, 
the desired AutoCAD file can be selected.

♦ DWG/DXF Units - This is a message window displayed when an AutoCAD file is opened in 
MicroStation. Set the Units to Survey Feet.

♦ Utilities > Batch Converter - This command is used to select the AutoCAD files for conversion, set 
up the conversion table, and convert the files.

○ Edit > Add Files - Used to select the AutoCAD files for conversion

○ Edit > V8 Save Options - Used to access the remapping CSV file.

○ Excel > Level - This button (in the Excel spreadsheet) queries the dgn file for AutoCAD level 
names and places them into the spreadsheet.

○ Excel Cut and Paste - In the Spreadsheet, MicroStation level names are cut from their current 
location and pasted next to the corresponding AutoCAD level. This tells the batch converter what 
to rename the AutoCAD levels too.

Fixing Converted Files with Mutiple Models - Some AutoCAD files may have multiple models, usually 
a sheet border model and a data model. Because the CDOT standard is one model per dgn, these will have to be 
separated

♦ Commands Used: File > Save As - Used to create a dgn file to contain the sheet border data.

♦ Delete - Used to remove the data from the Default Model.

♦ References > Attach - The file is attached to itself so that the sheet border data can be moved into 
the Default Model.

♦ Copy - Used to copy the referenced sheet border data into the Default Model.

♦ Models > Delete - Used to remove all models except the Default Model.

♦ Color Table > File > Default - Used to set the CDOT standard color table active.

♦ CDOT Menu > Drafting > Dimensions - Used to replace the AutoCAD dimensions.

♦ CDOT Menu > Tools > Text to Node - Used to group lines of text into paragraphs.

♦ annotationscale add - A MicroStation key in that adds the annotation scale attribute to the text.

♦ Change Text Attributes - Used to assign a CDOT text style to the text.
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Batch Conversion Of AutoCAD Files

Entire directories can be processed at one time using the Batch Converter. Using this option, a large number of 
files can be processed quickly. However, because only one of the files can be used to create the CSV file (the 
open file), many AutoCAD levels may be transferred to the MicroStation files. As the user finds MicroStation 
files with AutoCAD levels, those files can be used to create a new csv file and the Batch Converter can be re-
run on all the files. By repeating this process all of the AutoCAD levels will be gradually eliminated.

The steps below describe how to set up and run the Batch Converter.

Opening an AutoCAD file in MicroStation

1. From the File Open, open an AutoCAD (*.dwg) drawing file. (Change List Files of Type to CAD Files 
(*.dwg, *.dgn, *.dxf) to see the AutoCAD files in the selected directory). 

2. <D> the desired file then <D> OK. 

3. The DWG/DXF Units dialog box will appear. Verify the Units are set to Survey Feet and <D> OK. 
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4. Select Utilities > Batch Converter from the MicroStation menu. The Batch Convert dialog box is 
displayed.

5. Select Edit > Add Files from the menu.
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6. From the Select Files and Directories to Convert dialog box, Navigate to the directory containing the files 
to be converted, then highlight the files to be converted. <D> Done to complete the selection. 

7. Back on the Batch Convert dialog box, select Edit > V8 Save Options from the menu.
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Editing the CSV file

1. In the Save As V8 Options dialog box, <D> the Browse for CSV remapping file icon to edit the CSV 
file.

2. Navigate to the following directory: C:\Workspace\Workspace-CDOT_V8i\Standards-
Global\MicroStation\Tables\Level_Translation and select the V050000_Level_Update.csv 
file. The CSV file maps all of the previous AutoCAD layers to the standard CDOT MicroStation levels. 

0
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3. The CSV File field will be populated with the correct level mapping file. In the Save As V8 Options dialog 
box, <D> the Edit CSV remapping file icon. 

 

4. Microsoft Excel will activate. If the Security Warning dialog box appears, <D> Enable Macros. 
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5. In Excel, the Level tab will be active. <D> the  icon that is embedded in the Level cell.
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6. The fields under Level will be populated with the layers that are defined in the AutoCAD file.

In the example above, the first 12 levels listed are the AutoCAD layer names. The levels below them are 
the CDOT standard MicroStation levels.
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7. In order to remap the AutoCAD layers to the standard CDOT levels, you will need to manually populate 
the V8OutputLevel fields. To do this, find the desired CDOT standard MicroStation level in the Level 
column. Copy/Cut the level and paste it in the V8OutputLevel column directly across from the AutoCAD 
layer it is to replace.

In the above example, elements that were on the AutoCAD ‘TEXT’ layer will be placed on the 
‘DRAFT_Text-3’ level’ after conversion.

Note: Not all levels need to be populated. Blank entries in V8OutputLevel column will be ignored when 
processed and the AutoCAD layer (if occupied) will be brought into the MicroStation file as a new 
level. Be aware that some of the MicroStation levels are not in alphabetical order. And take care to 
search the entire list for the desired level.

Layers generated in AutoCAD that will be recreated as cells in MicroStation such as the Border, 
North Arrow, and Bar Scales do not need to be remapped because they will automatically come in 
on the correct levels when the standard CDOT workflows are followed.   Also, the layers used for 
creating AutoCAD viewports do not need to be remapped. Items on the Defpoints layer should be 
remapped to the level DRAFT_INFO_No-Plot.

The line styles, color, and weight of each level has already been taken into account through the 
CSV file. The translation variables in the CSV file have been set to remap all levels to bylevel 
symbology.

Note: Steps 13 and 14 below are available when converting a single file only. When doing a batch 
conversion, all of the models within the file will be converted.

8. In the Save As V8 Options dialog box, <D> the Filter tab. 
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9. Toggle off the Sheet Models check box.

10. <D> the Remap tab.

11. Check on the fields for Apply Level Mapping, Apply Line Style Mapping, Apply Color 
Mapping, and Apply Weight Mapping. <D> OK. 
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12. From the Batch Convert dialog box, <D> the Process Batch Convert Job icon.

13. The Files To Convert dialog box is displayed. From this dialog, <D> the Convert button.

14. When the processing is complete, <D> the Done icon to dismiss the dialog box.

This will convert all of the levels in the active file (as specified in the csv file) and convert the same levels in 
the other specified files. 

It is possible that the other files processed will have other AutoCAD levels. When these are discovered, repeat 
this conversion process on the previously converted MicroStation files. This will clean up the file that is 
currently being used and update the levels in other specified files. 
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Fixing Converted Files With Multiple Models

Sheet Layout models are not used in the standard CDOT configuration. However, those models will be retained 
in batch converted files. If the Sheet Layouts contain information that is needed, they will need to be saved to 
individual dgn files. To do this we will reference a dgn file to itself, selecting the desired sheet model, in order 
to copy information from the sheet layout to the default model.

1. Open the converted dgn file that contains the Sheet Layouts to be saved.

2. Select File > Save As and name the file appropriately for the Sheet Layout to be saved and <D> 
OK.

3. This will open the copy of the file. Delete all of the elements from the Default Model.

4. <D> the References icon from the MicroStation Primary Tools toolbar.

5. Select Tools > Attach from the References dialog box.

6. Select the open dgn file to attach it to itself. <D> Open.
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7. In the Reference Attachment Settings dialog box, select the desired Sheet Layout from the Model 
drop down menu. <D> OK.

8. <D> the Fit view control icon to display all of the elements in the view.

9. All of the elements in the view must be copied into the default model. This can be done using the Element 
Selector or with a Fence. 

Note: When making the copy be sure to snap to an element when copying and the same point on the 
element when placing the elements. This will ensure that they are at the same coordinates in the 
default model as they were in the sheet layout model.

10. After the elements have been copied, Detach the reference file. 
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11. <D> the Models icon from the MicroStation Primary Tools toolbar.

12. In the Models dialog box, <D> to highlight all of the models except the Default Model. <D> the 
Delete icon to remove all of the sheet layouts. <D> the ‘X’ to close the Models dialog box.

13. Steps 19 through 30 will have to be repeated for each sheet layout.

Converting a Single AutoCAD file

1. Open the desired AutoCAD file in MicroStation as described in steps 1 and 2 above.

2. Select File > Save As. 
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3. Change the Select Format to Save to MicroStation V8 DGN Files (*.dgn) and navigate to the 
appropriate folder under the Projects directory. The file will be automatically saved with the same name as 
the AutoCAD file with a different extension. You can rename the file at this time if you choose to do so. 
<D> Options. 

Note: Model files should be saved to the specialty group’s Reference_Files folder. Sheet files are saved 
under the specialty group’s Drawings folder. 

4. <D> Save in the Save As dialog box. The CSV file will execute and the AutoCAD drawing file will be 
converted to a MicroStation file. 

5. The file that is now open in MicroStation is the converted file. Running the CSV file changed the levels in 
the Model file to the CDOT Standard levels with bylevel symbology. 
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6. From the MicroStation menu, selected Settings > Color Table after the MicroStation drawing file has 
been created. 

7. In the Color Table dialog box, select File > Default.

8. <D> Attach. 

9. Verify that the conversion was successful. <D> the Level Display icon from the MicroStation Primary 
toolbar.
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10. In the Level Display window, <D> on the Used tab to sort the levels by those that have elements.   

Note: levels with elements will have a dot in this column. If no used levels are visible, <D> on the tab 
again. If the triangle on the tab is pointing down, the used levels are at the top of the window.)

Other Drawing Elements

Other updates will need to be made to the files so all drawing elements and sheet setups conform to the CDOT 
standards. 

All of the Sheet Layouts will need to be recreated using CDOT standard workflows. This means there can only 
be one Model for each MicroStation file. All of the sheet borders will need to be placed in their own separate 
file, called a Sheet File. Then, the Model file will be referenced to the Sheet File.   Please refer to the 
documents CDOT Sheet File Creation, CDOT Sheet File Creation Multiple Scales, and CDOT Creating 
Multiple Plan Sheets for additional information about this procedure. 
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1. Recreate all Dimensions and leader lines (placed by AutoCAD) using the standard CDOT dimension 
styles. The dimensioning commands are found in the CDOT menu under Drafting > Dimensions.

2. Erase all hatch patterns generated in AutoCAD recreate using the MicroStation Patterns tools, shown 
below. 

3. All blocks generated in AutoCAD will need to be replaced with the standard CDOT MicroStation Cells. 
The cells are found on the CDOT menu. Use the CDOT Menu Explorer to select the desired specialty 
group. Use the Category buttons and the Filter buttons to locate the cells within the menu. Select the 
desired cell from the list.
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Updating Text

Text created in AutoCAD with multiple text strings can be converted to a text node in MicroStation. Some 
multiple text strings created in AutoCAD will be translated into a text node when the file is converted. 
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1. To verify this, <D> the Element Information icon . Text Nodes will display under the General 
Tab. 

2. If not, select all text that will be combined into a text node using the Element Selection tool. While in 
the Element Selection command, hold down the Ctrl key to select individual text strings. Highlight 
them in the order they are to be placed into the text node. 

Note: Do not Window around the multiple lines of text because the text strings may not merge in the 
desired order.
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3. Select the Text to Node utility from the CDOT Menus under Add On’s. 

4. <D> the Convert Text Element to Text Node icon 

5. The following dialog box will appear. The selected text will be anchored to the cursor. 
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6. Check on Delete Original, set the Justification, and leave the Line Spacing set to 1.00. Place the text in 
the desired location.

Note: If the Justification is set to anything other than Left Bottom, double <D> on the text after it is 
placed. The text will be brought into the Text Editor dialog. <D> again on the screen to place the 
text to its proper location and close the dialog.

7. Select all text and key-in annotationscale add. The text will now recognize the MicroStation 
Annotation Scale Factor. 

8. Update the text style by <D> Change Text Attributes. Select the desired CDOT Text Style and select 
the text placed previously in AutoCAD.

  

9. All fractions placed in AutoCAD will need to be re-typed in MicroStation so the format conforms to 
CDOT standards.
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Compressing the Model File

1. After all changes and updates have been made to update the drawing into MicroStation using CDOT 
standards and standard workflows, you will need to compress the drawing in order to remove all AutoCAD 
information stored in the drawing buffer. This will ensure that AutoCAD data does not get repopulated into 
the drawing. Select File>Compress>Options.

2. Under Compress > Options, verify that all options are checked ON except Delete Text Elements 
Containing Only Spaces. 

3. Once the correct options have been selected, <D> the Compress button.



CATM- 24 Colorado Department of Transportation

 Converting AutoCAD Files to MicroStation CDOT  Workflows


	Workflow MS 10 - Converting AutoCAD Files to MicroStation
	Workflow Outline
	Batch Conversion Of AutoCAD Files
	Opening an AutoCAD file in MicroStation
	Editing the CSV file
	Fixing Converted Files With Multiple Models
	Converting a Single AutoCAD file
	Other Drawing Elements
	Updating Text
	Compressing the Model File



